Skip to main content
Matrix42 Self-Service Help Center

Device Enrollment Program: Troubleshooting Guide

Troubleshooting Guide for Device Enrollment Program

Check your Device Enrollment Program Connection

In Silverback

  • Open your Silverback Management Console
  • Login as an Administrator
  • Navigate to Admin
  • Select Device Enrollment Program
  • Check the last time updated information 

troubleshooting_dep_02.png

In Apple Business Manager

  • Open Apple Business Manager
  • Login with your Credentials
  • Navigate to Settings
  • Navigate in the Middle Pane to MDM Servers
  • Click on your Silverback Server 
  • Check the Last connected at information

troubleshooting_dep_01.png

Both information should be equal. If not you may need to update your Device Enrollment Program Token. Please refer to: Apple Deployment Programs X: Renew your DEP Token

Check your Device Synchronization

In Apple Business Manager

  • Open Apple Business Manager
  • Login with your Credentials
  • Navigate to Settings
  • Navigate in the Middle Pane to MDM Servers
  • Click on your Silverback Server 
  • Scroll down to the assigned Devices Overview 

troubleshooting_dep_03.png

In Silverback

  • Open your Silverback Management Console
  • Login as an Administrator
  • Navigate to Admin
  • Select Device Enrollment Program
  • Check the Account Overview

troubleshooting_dep_04.png

Most issues with Apple Deployment Programs VI: Manually add devices to DEP are that you missed to assign the device to your corresponding Server 

Assign Devices

In Apple Business Manager

  • Open Apple Business Manager
  • Login with your Credentials
  • Navigate to Device Assignments 
  • Enter the Serial Number of your device
  • Under actions select Assign to Server
  • On MDM Server select your Silverback Server
  • Click Done 
  • Wait a couple of minutes and recheck that the device is assigned to your Server

In Silverback

  • Open your Silverback Management Console
  • Login as an Administrator
  • Navigate to Admin
  • Select Device Enrollment Program
  • Press Refresh 
  • Wait a couple of minutes and recheck that the device amount is increased with +1 device

Check your User Credentials

Most issues during device setup are due to wrongly used credentials

Silverback Settings

  • Open your Silverback Management Console
  • Login as an Administrator
  • Navigate to Admin
  • Select Device Enrollment Program
  • Click Settings
  • Check if under Settings: Active Directory Authentication is enabled or disabled
    • If enabled: You need to enter Active Directory credentials on the device
    • If disabled: You need to create an OTP and enter the corresponding username with OTP on the device.
      • You will find the corresponding OTP information during Self Service Provisioning

troubleshooting_dep_07.png

Try your credentials

  • Open your Browser in Incognito Mode
  • In Silverback Device Enrollment Programs settings you can find your Activate Apple Location 
  • Copy and Paste this URL to your Browser
  • You should see now a Login Message

troubleshooting_dep_05.png

  • Try to login with your credentials
    • Either Active Directory credentials
    • Or Username and OTP
  • When your credentials are correct, you will download a *.mobileconfig file

troubleshooting_dep_06.png

If your download doesn't start you are using incorrect credentials

Check Logs

Silverback is writing by default log files for the Device Enrollment Program. For further investigation it is advisable to look at the log files. 

For wrong credentials

troubleshooting_dep_09.png

  • If you are trying from a device, you will see the following message(s)

troubleshooting_dep_10.png

For Synchronization Issues

  • Navigate to Device Enrollment Program
  • Check if you find any errors 
  • Usually  the logs should look like this 

troubleshooting_dep_08.png

 

  • Was this article helpful?